Water cannon at low timescale not turning into steam

#1
Hello,

When I've built a machine that uses steam cannons and started the game in slow-mo, I've found strange behavior.
At regular timescale, a heated water cannon turns into steam cannon after ~0.5 sec of heating. So at timescale 20% it SHOULD be activated after ~2.5 sec, right?
But if simulation has timescale <=20% from the very beginning, it doens't become steam cannon even after 20-30 sec, which should be equal to 4-6 sec of real timescale. I've tried to wait up to 2 minutes, but it still was water only. As you can see on the screenshot, the cannon is red, meaning it is definitely headed enough, but it is still shooting water, not steam.
1234.png


But SOMETIMES it turns to steam after random time amount. I've tried the same thing starting the simulation at 10%, 15%, and 25% speed, and it seems that probability of finally becoming a steam cannon depends on timescale.

Retried it ~10 times, restarted the game several times, on different maps. Never could activate steam mode in 3 sec. And 2 times it finally turned on to steam mode after minute or two.
The reproduction steps are the following:
1) Start the game
2) Enter Sandbox map
3) Build machine like on the screenshot (place water cannon, torch and pin).
4) Drop timescale down to 20%
5) Start the simulation and press Y (to activate the cannon)
6) Watch it not becoming steam cannon.

All mods are disabled.
 
Top