V 0.2 flaming balls and torches extinguishing too easily

#1
I've been using torches and flaming torches as steam-cannon heaters for several of my contraptions - and have found that the new update seems to have issues with flames going out where they worked fine before. It isn't obvious what the cause of this is - it might possibly be increased sensitivity to vibration, or possibly stray puffs of steam.
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#2
Hmm, I can't seem to reproduce unless water hits them.
 
#3
Try this contraption - the torches worked reliably before (not at 100% speed, obviously - but I don't think frame rate is the issue, and I'm getting the same results if I run it at low time %). It seems to run fine for a bit, but loses a torch at some point - followed by the others as it starts to spray water around. It seems to be more prone to doing it while turning, which makes me wonder whether it is a jolt or something putting the torch out - though there are also so odd effects with stray puffs of steam popping up in unexpected places, which might possibly be connected.

Attached Files
HPL-134.bsg
 
#4
After further investigation with several of my designs, I'm now more or less convinced that it is steam blowback on the torches/flaming balls that is the issue. And the good news is that I think I can design around it, in most cases - so if it isn't a simple fixable bug, I can still build steam-powered contraptions, with more complexity than ever...
 
Top