Transform events sometimes don't activate

#1
I have a transform event that moves a group of objects including insignia and for some reason for one of the insignia sometimes it gets moved with a delay after I have already tried to move it a few more times and just does all the transforms instantly and for some reason one of the transforms which both moves and rotates it only has the movement applied. The problem doesn't apply to the rest of the objects that are being moved with exactly the same transform events. Is this possible to be caused by the fact that I'm also deactivating and activating the insignia? I need to start making a list of all the inconsistencies that I have found in the events system. Every time I try to do something more complicated I come across weird behavior.
 
#2
I just tested it by moving the insignia instantly and left only the solid objects to move for a period of time and now it works fine so I guess the bug is caused when you try to trigger an insignia that is moving at that moment and somehow breaks the movement.
 
#3
Hey svetli97!

Thank you very much for reporting this, could you provide us with an example level where this occurs? I'll be happy to take a look if anything is off!
 
Top