TGYD`s Building Tools [spaar`s Mod Loader] [for v0.45]

The duplicate selection tool totally breaks block connections of the original selection and the new duplicate. Swivels and hinges disconnect and reattach to other things.
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
The duplicate selection tool totally breaks block connections of the original selection and the new duplicate. Swivels and hinges disconnect and reattach to other things.
That could have to do with the order of the blocks (The order in the .bsg file, I think), have you tried selecting everything, then deselecting stuff in the order you want them to be connected to?
 
correct except you need to drag the contents into the "mods" folder not "besiege_data"
Not correct. Spaars mod loader, being installed by dragging the contents, as instructed above, and as in the instructions at the beginning of this thread, does not actually work for your mod. This was the problem; solution addressed below.

The modloader has no rar files... Are you sure you didn't mix it up with building tools?

Since the intructions are quite clear: http://forum.spiderlinggames.co.uk/index.php?threads/spaars-mod-loader-1-4-4-besiege-v0-32.519/
Haha indeed that was it. I was following the instructions from this thread, to install Spaars, which say to extract the rar version of it, which did not work.
Code:
1. Get spaar's Mod Loader. (broken link)
---(If you have a BlockTransformTools.dll file in your mods directory remove it)
2. Open the .rar archive, if you can't you need an archiving software such as WinRAR
3. Drag the contents of the archive (.rar) into your Mods directory in the Besiege Directory.
Previously, I'd found the RAR for Spaar's on Google, due to the broken link, then followed the rest of the instructions.
However, as soon as I downloaded the exe, with ITR's link and instructions, and installed that, the mod was back up and running again.
 
Not correct. Spaars mod loader, being installed by dragging the contents, as instructed above, and as in the instructions at the beginning of this thread, does not actually work for your mod. This was the problem; solution addressed below.
As I made this mod and set the archive up for installation, the explanation of installing is correct, and it does work.
I can only direct you to your own misunderstanding if you find incorrect. And this thread is exclusively for my mod, the install instruction are for just that, spaars modloader has to be installed in a few more steps, or using the installer. Right now you are only contributing to confusion for other people with your ignorance.
I hope for other peoples' sake you stop posting about this and just follow the two sets of instructions correctly.
 
Hmm... I'll mess with it.
Reading this, my first reaction was: That's not possible, how blocks are joined together cannot be affected by what we do in building mode. But it turns out there was something I would classify as an error in the Besiege code. I have a hot-fix for that integrated in Building Tools now as far as I can see, and after playtesting that a little I'll submit this new version.
 
Ok I'm new to it, but as far as I am concerned about my knowledge, I can't make things go intersected WHILE playing
editing is ok, the I hit play and everything colides out and crashes itself....
help PLz
 
Alrighty, I wont say another thing after this post on the matter, though I would recommend you try following the instructions yourself on a clean computer. I know you made the mod, but it doesn't mean you wrote the correct instructions for people to install it. Everyone makes mistakes.

Now it may be just my computer here, as I've only tried it on one of my machines, but I found, with absolute certainty, that Spaars has to be installed via the actual installer, not extracted, from the RAR version, as you instruct, in order to work with your mod.
This also might explain why 50% of posts in this thread are people being confused about why it doesn't work for them.

It would be pretty easy to just fix the link to the Spaars thread though, and change your instructions to say "1. Install Spaars mod loader, from the downloadable exe file, in the official Spaars Mod Loader thread."
You could then even change the remaining steps to be relevant to the installation of your mod.

OK, I'm done. Hopefully those who can't figure this out by themselves will see it, even if you don't correct the instructions. Communication is important.. =/
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
Alrighty, I wont say another thing after this post on the matter, though I would recommend you try following the instructions yourself on a clean computer. I know you made the mod, but it doesn't mean you wrote the correct instructions for people to install it. Everyone makes mistakes.

Now it may be just my computer here, as I've only tried it on one of my machines, but I found, with absolute certainty, that Spaars has to be installed via the actual installer, not extracted, from the RAR version, as you instruct, in order to work with your mod.
This also might explain why 50% of posts in this thread are people being confused about why it doesn't work for them.

It would be pretty easy to just fix the link to the Spaars thread though, and change your instructions to say "1. Install Spaars mod loader, from the downloadable exe file, in the official Spaars Mod Loader thread."
You could then even change the remaining steps to be relevant to the installation of your mod.

OK, I'm done. Hopefully those who can't figure this out by themselves will see it, even if you don't correct the instructions. Communication is important.. =/
Too be fair, he never wrote that spaar's modloader is in the rar file he provided. He just said you would have to install it.
And you don't have to use the installer, you can also do a manual install, as long as you download the correct zip (the one on spaar's thread) :-P
 
Ok I'm new to it, but as far as I am concerned about my knowledge, I can't make things go intersected WHILE playing
editing is ok, the I hit play and everything colides out and crashes itself....
help PLz
That's the intended behaviour, you only disable the intersection warning prohibiting you from placement. Stuff will still collide in simulation.
 
It would be pretty easy to just fix the link to the Spaars thread though, and change your instructions to say "1. Install Spaars mod loader, from the downloadable exe file, in the official Spaars Mod Loader thread."
The fact that you still think I provided the install instruction for spaar's modloader is ridiculous, of course you need to follow those first when I tell you to install his loader first. Then you proceed with my install instructions.
I must say you managed to lower the standard more than I thought possible, I made it more than idiot proof enough now. If you can't figure it out from there, then there is no helping you.
 
That's the intended behaviour, you only disable the intersection warning prohibiting you from placement. Stuff will still collide in simulation.
but how about those modded creations from steam workshop for eg, they do not break...
how can i use the mod properly? because there is no sense at all to build a thing totally refined to break out on 'play'
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
but how about those modded creations from steam workshop for eg, they do not break...
how can i use the mod properly? because there is no sense at all to build a thing totally refined to break out on 'play'
They probably just pay really much attention to how close they put the blocks :p
Do you have an example of a machine you think does this?
 
Um Shade said this mod allowed you to add more than 1 vehicle is there an easier way to do something like select all on your vehicle, and when I do copy and duplicate a vehicle as sooon as I start the level they just explode and implode? But good mod! And is there a way to add 2 different vehicles from the load list because I want to add a castle and a tank but I cant figure out how? Thanks Again,
Ben
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
Um Shade said this mod allowed you to add more than 1 vehicle is there an easier way to do something like select all on your vehicle, and when I do copy and duplicate a vehicle as sooon as I start the level they just explode and implode? But good mod! And is there a way to add 2 different vehicles from the load list because I want to add a castle and a tank but I cant figure out how? Thanks Again,
Ben
ctrl+a then open a vehicle, then move the selected machine away so they're not inside each other
Or don't have anything selected then choose import in the load menu and it get's selected, I think it was.

For multiple machines, just repeat the process.
 
ctrl+a then open a vehicle, then move the selected machine away so they're not inside each other
Or don't have anything selected then choose import in the load menu and it get's selected, I think it was.

For multiple machines, just repeat the process.
No just use the import machine button ITR, tsk tsk....

But there is currently a bug where machines act differently when imported and I don't know why, I'm not sure I can fix that.
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
No just use the import machine button ITR, tsk tsk....
But there is currently a bug where machines act differently when imported and I don't know why, I'm not sure I can fix that.
I mentioned import, just couldn't remember where it was >.>
Also, he asked specifically if there was an easier way to select the whole machine <.<
 
Top