TGYD`s Building Tools [spaar`s Mod Loader] [for v0.45]

It used to work, but I haven't played for a week. I've updated to Building Tools v0.58 and Spaars 1.4.4, but it still doesn't load up. There's no 'Mods' button in Besiege to turn them on.. I thought there was one somewhere, in the settings, but I don't see it.
Does anyone know how to get it working? Also does anyone know a good mod for pushing the limits of block settings, or will that possibly be a feature at some point?

Cheers,
Tony
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
It used to work, but I haven't played for a week. I've updated to Building Tools v0.58 and Spaars 1.4.4, but it still doesn't load up. There's no 'Mods' button in Besiege to turn them on.. I thought there was one somewhere, in the settings, but I don't see it.
Does anyone know how to get it working? Also does anyone know a good mod for pushing the limits of block settings, or will that possibly be a feature at some point?

Cheers,
Tony
There's no mods button, if you have the modloader installed you can press ctrl+m to toggle mods, but that's it.
If nothing pops up you haven't installed the modloader correctly.
 
Alrighty, well Ctrl+M doesn't do anything.. I installed the spaars mod loader the same way as before, by extracting the contents to the mods directory, as per the instructions, but perhaps the way it's installed has now changed then.
What's the correct way to do it though? I can't find any other methods =/
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
Alrighty, well Ctrl+M doesn't do anything.. I installed the spaars mod loader the same way as before, by extracting the contents to the mods directory, as per the instructions, but perhaps the way it's installed has now changed then.
What's the correct way to do it though? I can't find any other methods =/
Did you remember to replace Assembly-UnityScript?
 
I've been playing around with this mod for quite some time at v0.30. Building tools work well, except importing machines are buggy. Wooden poles are loaded half their size as well as double wooden blocks, causing machines that use them to fall apart. Haven't had the time to update to v0.32, though.
 
Can Someone make a tutorial on how to install this mod?
get spaars mod loader, and install, it will install to the right place on its own. Then go to Steam, Right click besiege, Properties, Local files, Browse local files, then besiege_data, Mods, then download a mod(this one) and open it in winrar(if you dont have it, go to the website and download it)then drag the contents of the mod file into the mods file in the besiege_data. Hopefully this helps. (that should work, if not, you must have done something wrong)
 
Did you remember to replace Assembly-UnityScript?
Sorry no, I hadn't heard of that.. it's not mentioned in the instructions, and it worked perfectly before the update, without it. =/
Is this new Assembly thing something that's now required? It should definitely be added to the instructions if so lol, you're the first person I've seen mentioning it though. You're not trolling are you? This is confusing enough already >.<
What do you know about it that you can tell me? I would like to get the mod working again if possible.

And thank you Kirk, for compiling the instructions simply, but there are a few missing. Also, I'm a bit confused as to what you mean by "get spaars mod loader, and install, it will install to the right place on its own", as it is a RAR file, there is no installer, and other versions of the instructions say to extract it to the mods folder, which I did before, which worked, until the latest update. I downloaded the latest and did the same again, as per the instructions, to the letter, but it doesn't work.

Does anybody, who knows how to get it working properly, possibly have the time to put all the current installation instructions in one place? I really miss this mod =(

I'm on Windows 7 x64 Professional, and am running 2 GPUs, if either of those would be relevant to why it's not working..
Any ideas, or any other information I could provide that might help solve this? I will provide information, if I am provided with the information of which information I should provide.
 
Last edited:

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
Sorry no, I hadn't heard of that.. it's not mentioned in the instructions, and it worked perfectly before the update, without it. =/
Is this new Assembly thing something that's now required? It should definitely be added to the instructions if so lol, you're the first person I've seen mentioning it though. You're not trolling are you? This is confusing enough already >.<
What do you know about it that you can tell me? I would like to get the mod working again if possible.

And thank you Kirk, for compiling the instructions simply, but there are a few missing. Also, I'm a bit confused as to what you mean by "get spaars mod loader, and install, it will install to the right place on its own", as it is a RAR file, there is no installer, and other versions of the instructions say to extract it to the mods folder, which I did before, which worked, until the latest update. I downloaded the latest and did the same again, as per the instructions, to the letter, but it doesn't work.

Does anybody, who knows how to get it working properly, possibly have the time to put all the current installation instructions in one place? I really miss this mod =(

I'm on Windows 7 x64 Professional, and am running 2 GPUs, if either of those would be relevant to why it's not working..
Any ideas, or any other information I could provide that might help solve this? I will provide information, if I am provided with the information of which information I should provide.
The modloader has no rar files... Are you sure you didn't mix it up with building tools?

Since the intructions are quite clear: http://forum.spiderlinggames.co.uk/index.php?threads/spaars-mod-loader-1-4-4-besiege-v0-32.519/

Windows (Installer)
There is a graphical installer for Windows available. Just download ModLoader Installer.exe, save it anywhere on your computer and run it.
If the installer doesn't automatically detect it, use the Browse button to select your Besiege installation, select a version and press "Install Mod Loader".
The installation might take a while, depending on your internet connection. The program might appear to freeze during the installation but it's just working in the background.
To update the mod loader, you can just run the program again, select the new version and press Install again.

Linux & Windows (Manual Installation)
Locate your Besiege installation. If you installed Besiege via Steam, this will usually be in C:\Program Files (x86)\Steam\steamapps\common\Besiege.
I will from now on refer to this directory as simply Besiege in any paths.
Copy the file Assembly-UnityScript.dll into Besiege/Besiege_Data/Managed.
When asked, choose to replace the original file. You may also want to make a backup of the original file before doing this.
Then create the folder Besiege/Besiege_Data/Mods. Copy SpaarModLoader.dll and the Resources folder into it. You will also place any mods you install into this folder.
 
I've been playing around with this mod for quite some time at v0.30. Building tools work well, except importing machines are buggy. Wooden poles are loaded half their size as well as double wooden blocks, causing machines that use them to fall apart. Haven't had the time to update to v0.32, though.
Wasn't aware that happened in 0.3, regardless it should not happen in the most recent version. If it does, it might be more of a Besiege bug than Building Tools one.
 
get spaars mod loader, and install, it will install to the right place on its own. Then go to Steam, Right click besiege, Properties, Local files, Browse local files, then besiege_data, Mods, then download a mod(this one) and open it in winrar(if you dont have it, go to the website and download it)then drag the contents of the mod file into the mods file in the besiege_data. Hopefully this helps. (that should work, if not, you must have done something wrong)
correct except you need to drag the contents into the "mods" folder not "besiege_data"
 
Top