Spaar's mod loader not working properly

#1
The ctrl+k, ctrl+m and ctrl+ j dont work
I did exactly what the "README" text file said but the mod loader properly wont work.
I've been on for hours trying to fix it and I've given up.
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#2
Post an image of your data structure. (All folders and where you have them)
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#5
I dont get a output_log.txt file (and my laptop wont allow me to print screen) But If I post the Mod file is it possible you could check inside to see whats wrong?
Check here (Under "Player") to see where your output log is: https://docs.unity3d.com/Manual/LogFiles.html

You probably have a program on your computer for taking screenshots, if you have windows search for "Snipping Tool", if you gave osx try pressing command(⌘)+Shift+4 or 3
 
#6
Check here (Under "Player") to see where your output log is: https://docs.unity3d.com/Manual/LogFiles.html

You probably have a program on your computer for taking screenshots, if you have windows search for "Snipping Tool", if you gave osx try pressing command(⌘)+Shift+4 or 3
Alright, I'll add a file (It shows you my besiege mod files in the mod folder I made). My output log is: _EXECNAME_Data_\output_log.txt" After that it says "~/.config/unity3d/CompanyName/ProductName/Player.log" Hopefully this helps
 

Attachments

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#7
The folder has to be named "Mods".
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#9
All those files in that picture ARE in the mods file. Im showing you the contents.
No, I mean, it has to specifically be named "Mods", written that way (without quotes).
Can you also take a screenshot of the folder you have your Mods folder in, and, the folder that folder is in?
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#11
Did you do a manual install, or use the installer? Did you remember to replace Assembly-UnityScript?
 
#12
Did you do a manual install, or use the installer? Did you remember to replace Assembly-UnityScript?
Yes, replaced the Assembly-UnityScript.
The installation of the Modloader was done automatically by my computor. Do you think I should copy all the files in the Mods file and re-install the Modloader? After re-installing it and replacing the Assembly-UnityScript (and re-pasting the contents of the mods file back in) do you think they will work?
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#13
Yes, replaced the Assembly-UnityScript.
The installation of the Modloader was done automatically by my computor. Do you think I should copy all the files in the Mods file and re-install the Modloader? After re-installing it and replacing the Assembly-UnityScript (and re-pasting the contents of the mods file back in) do you think they will work?
Hmm, before that, have you tried deleting your config folder? Try that
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#15
Where is that? And how is my configiration folder going to help?
It's Mods/Config, sometimes it just helps, idk why. If it still doesn't work, try to verify the game cache, then reinstall the modloader (In your steam library, right click besiege, choose properties > local files > verify integrity of game cache)
 
#16
It's Mods/Config, sometimes it just helps, idk why. If it still doesn't work, try to verify the game cache, then reinstall the modloader (In your steam library, right click besiege, choose properties > local files > verify integrity of game cache)
Re-Installed the mod loader and verified the integrity of the game cahe.
But alas, it corrupted so I had to very the integrity of the game cache AGAIN, and, well...It doesnt work...(I replaced or the folders in the mod folder.)
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#17
Re-Installed the mod loader and verified the integrity of the game cahe.
But alas, it corrupted so I had to very the integrity of the game cache AGAIN, and, well...It doesnt work...(I replaced or the folders in the mod folder.)
Did you try to do the manual install this time?
Can you upload "Besiege/Besiege_Data/output_log.txt"?
 
#18
Did you try to do the manual install this time?
Can you upload "Besiege/Besiege_Data/output_log.txt"?
A bit too late for that as I verified the integrity of the game cache so now the game works.
[EDIT]: I found a output_log.txt file in Besiege>Besiege_data so Ill add it. (I'm not sure if it has anything to do with the game crash I had last night but I'll try anyway.)
 

Attachments

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#19
A bit too late for that as I verified the integrity of the game cache so now the game works.
[EDIT]: I found a output_log.txt file in Besiege>Besiege_data so Ill add it. (I'm not sure if it has anything to do with the game crash I had last night but I'll try anyway.)
Yeah, no, if you uninstalled the modloader it won't help. It only stores the last session.
 
Top