spaar's Mod Loader (1.7.1) [Besiege v0.45a]

Important note: The mod loader does not currently work with the Multiverse update!
If you want to build machines using mods, you can still use the older version of Besiege. (It's available using the Steam beta feature.)
I'm sorry to bug you, but can you tell me the way to install the older version of Besiege? Nothing useful comes up then asking dr.google.
 

spaar

Active Member
had the older version of your mod loader and installed your new one on .45 and a white screen appears and bugs it all out.
That normally means something went wrong during the installation. Re-download the game on Steam (or "Verify game files") (make sure you're downloading the old version, not v0.60). Then re-download the mod loader and try installing it again.
(Re-downloading is important, a file may have been corrupted in the download.)
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
You can also try updating your graphics drivers
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
Just installed the loader for the prevbuild version and i'm stuck with this in the top left corner. was wondering if i just installed it wrong. can't find anything online.
It looks like you have an old mod in your mods folder that's breaking stuff
 
I have a error. The mod works and all, but when i open the mod loader console i get a red message that spams the whole console saying ''MissingFieldException: Field '.OptionsMaster.musicVolume' not found.'' any help?
 

spaar

Active Member
I have a error. The mod works and all, but when i open the mod loader console i get a red message that spams the whole console saying ''MissingFieldException: Field '.OptionsMaster.musicVolume' not found.'' any help?
1) Are you trying to use mods on the v0.60 update (Multiverse)?
2) If not, my guess would be that that is caused by an outdated mod. If you upload your output_log.txt file from Besiege_Data/ I can probably tell you which one.
 
1) Are you trying to use mods on the v0.60 update (Multiverse)?
2) If not, my guess would be that that is caused by an outdated mod. If you upload your output_log.txt file from Besiege_Data/ I can probably tell you which one.
no, i dont use it on the multiverse update and before i even downloaded any single mod, (only your mod loader) i already got the message spamming the console. but still here's my output.log.txt file on pastebin (or if you want the whole thing you can download it). https://pastebin.com/50hEnyaE
 

Attachments

Last edited:

spaar

Active Member
With v0.6.0-6437, which version do I download?
The mod loader doesn't support v0.60 at the moment. See https://github.com/spaar/besiege-modloader/issues/65.

no, i dont use it on the multiverse update and before i even downloaded any single mod, (only your mod loader) i already got the message spamming the console. but still here's my output.log.txt file on pastebin (or if you want the whole thing you can download it). https://pastebin.com/50hEnyaE
According to the file paths in your log, you seem to be using Besiege v0.42. The current mod loader version is for v0.45 and will not work with another version. Use the appropriate version of the mod loader if you must use Besiege v0.42, but keep in mind that many mods do not provide old releases and will only work with v0.45 anyway. Also, the log says a bunch of game files are corrupted, so you should probably redownload the game as well.
 
The team behind Besiege should give the modders more information regarding the changes and the new content of the update, the potential of the new level editor is huge, it is a pity that they have to take so much to decipher as it works :(
 
Top