spaar's Mod Loader (1.7.1) [Besiege v0.45a]

spaar

Active Member
Hey, Spaar those links to the Visual Studio template, as well as your tutorial, don't work. Just letting you know.

Ps: ITR, you didn't see anything
Oh, right, I forgot to update the template link. Thanks for mentioning it. Still haven't made a version of the tutorial to release again I'm afraid, so I should probably remove that link for now.
 
im new and i have no fucking clue as to what i am doing.

Tell me in the least amount of words while explaining the most amount of information, in a summarization, how to cram the mods into the game using the mod loader
 

Lench

Active Member
im new and i have no fucking clue as to what i am doing.

Tell me in the least amount of words while explaining the most amount of information, in a summarization, how to cram the mods into the game using the mod loader
  1. Use the mod loader installer that installs it automagically for you.
  2. Open your Besiege installation directory (Right click on Besiege in Steam -> properties -> local files -> Browse local files).
  3. Put mod .dll files in Besiege/Besiege_Data/Mods/ folder, which will then be loaded by the mod loader.
 
Last edited:
IT IS NOT WORKING I installed the .exe version I'm on windows 10 and now the game keeps crashing after I launch it. I unistalled using the .exe and now it's the same it keeps crashing plz I don't want to uninstall the hole game.
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
IT IS NOT WORKING I installed the .exe version I'm on windows 10 and now the game keeps crashing after I launch it. I unistalled using the .exe and now it's the same it keeps crashing plz I don't want to uninstall the hole game.
If you're using the steam version, just verify your cache then try again
If you're using the other one, replace assembly-unityscript.dll with the one in the archive
 
Last edited:
If you're using the steam version, just verify your cache then try again
If you're using the other one, replace assembly-unityscript.dll with the one in the archive
Thanks for the fast reply I did for the steam version what you said now i don't have any problems about the game :) but I still can't add any mods on v0.30 :(
The "Spaar's modloader" page is not working is it normal ?
I'm using the link in the "Precision building project 2" page under your NEW COMPUTER stuff
I tested other mods like your rocket thrusters but when I get back on the game it didn't change anything. I'm pretty sure to place the mods as writen and the good version of the mod (I'm always taking the latest or the only one of the page) but it just won't work.
I've already used your mods months ago (before the 2nd island) and I had less problems:(.
 
Last edited:

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
Thanks for the fast reply I did for the steam version what you said now i don't have any problems about the game :) but I still can't add any mods on v0.30 :(
The "Spaar's modloader" page is not working is it normal ?
I'm using the link in the "Precision building project 2" page under your NEW COMPUTER stuff
I tested other mods like your rocket thrusters but when I get back on the game it didn't change anything. I'm pretty sure to place the mods as writen and the good version of the mod (I'm always taking the latest or the only one of the page) but it just won't work.
I've already used your mods months ago (before the 2nd island) and I had less problems:(.
All the links to forum posts got broken when the forum migrated, I must have forgotten PBP2 has a link to this page. I'll update it now

Check the first page on this thread to find the correct download for Spaar's Modloader
 

spaar

Active Member
its not working on Windows at this time ( August of 2016 )
That's not really true, it works just fine for me and many other people. If you have problems with it I'm happy to try and help you but you need to give me a bit more information than just "it's not working".
 
what i mean by not working is the modloader crashes my game when i try to run it with the " Spaar's Mod Loader " and i cant run the installer its self
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
what i mean by not working is the modloader crashes my game when i try to run it with the " Spaar's Mod Loader " and i cant run the installer its self
If you can't run the installer, how can you have spaar's modloader installed...? Or did you do a manual install?
Either way, reinstall besiege then try again. If it still doesn't work, try uploading your output log.
 
Quick suggestion: to help clarify installation for Mac users that use Steam (which I assume is the vast majority), you might consider adding this to the instructions:

"Open your Steam library, and right click on "Besiege." On bottom of the toolbar, click on "Properties." A pop-up should appear; go to "Local Files," and then click on "Browse Local Files." A regular Finder window-folder should appear, revealing the Besiege.app. Right-click the app and press "Show Package Contents."
(THEN the rest of the instructions above apply...)

Thought it might be a good idea to add this since I had a lot of trouble finding "Show Package Contents" when I first downloaded this mod. Hope this helps anyone, cheers!
 
Hello, Tornait here, new member. I'm on a Mac, accessing Besiege through Steam. I looked and looked, but there is no Data file to be found in the Resources folders... It only contains a file known as "shortcut.icns"... Please help! Am I doing anything wrong?


Edit: Found it. Now, this question is quite stupid, but do I put the mods into the modloader's resources folder? Nothing is happening. I need some further hand-holding and explaination, please.
 
Last edited:

spaar

Active Member
Quick suggestion: to help clarify installation for Mac users that use Steam (which I assume is the vast majority), you might consider adding this to the instructions:

"Open your Steam library, and right click on "Besiege." On bottom of the toolbar, click on "Properties." A pop-up should appear; go to "Local Files," and then click on "Browse Local Files." A regular Finder window-folder should appear, revealing the Besiege.app. Right-click the app and press "Show Package Contents."
(THEN the rest of the instructions above apply...)

Thought it might be a good idea to add this since I had a lot of trouble finding "Show Package Contents" when I first downloaded this mod. Hope this helps anyone, cheers!
That's a good idea. Due to not owning a Mac myself I don't know first-hand how everything works, so thanks for the contribution.

Hello, Tornait here, new member. I'm on a Mac, accessing Besiege through Steam. I looked and looked, but there is no Data file to be found in the Resources folders... It only contains a file known as "shortcut.icns"... Please help! Am I doing anything wrong?

Edit: Found it. Now, this question is quite stupid, but do I put the mods into the modloader's resources folder? Nothing is happening. I need some further hand-holding and explaination, please.
You put the mods directly into the Mods folder, where SpaarModLoader.dll is also located.
 

spaar

Active Member
Just release version 1.4.2 which should add compatibility for the newly-released Besiege v0.32 as well as a small bugfix.
 
Hello, Tornait here again. Now something is not working again. Updated Besiege, updated all mods and stuff, but now the UI for mods is not working. I'm trying control+j, control+k and control+m, but nothing is showing up. Currently the only mod that is working is not even working in full. Please help. Still on a Mac. If there is anyone who can help me, please. I'm running into way too many problems...
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
Hello, Tornait here again. Now something is not working again. Updated Besiege, updated all mods and stuff, but now the UI for mods is not working. I'm trying control+j, control+k and control+m, but nothing is showing up. Currently the only mod that is working is not even working in full. Please help. Still on a Mac. If there is anyone who can help me, please. I'm running into way too many problems...
You probably installed mods that aren't updated. Disable them, then try again
 
Top