Low CPU usage on all cores despite low fps

#1
Hi all,

when I load a large creation or try to host a lot of players, naturally my fps are dropping. What is confusing me is that my cpu usage is still at around 60 % on every core. My temps are fine at 65° C (Thermal throttling happens at 104 °C). My GPU usage is ~0% when I have 2 fps because it has nothing to do. In benchmarks I can get to 99% CPU usage.

My system:
CPU: i5 3570k @ 4.2 GHz, stock voltage
RAM: 16 GB DDR3 1800 MHz
MB: ASROCK Z77 Pro 3
GPU: Radeon R9 390
PSU: 500W be quiet! System Power 7

What is happening here? Why is not even the main core at 100% usage?
 

Sanpyr

Active Member
#2
have you tried setting the priority for besiege to high or realtime? it doesn't matter if you have all the cpu power in the world, if it isn't using it on the things you want.
 
#3
Yes, that fixed it, thank you! I'm still getting the same 2 fps on my test machine, but now my cpu spikes to 100%. And who knows, maybe I had an average of 1.7 fps and now I have 1.9 fps and that represents an performance increase of a whooping 10 %. Will have to test some more at more reasonable framerates.
 
#4
Wait, why is it that when I drop the speed so I get like 35 fps, my CPU is once again not at a 100 %, but instead moving in the range of 65% to 85 % with it's most used core?
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#6
I think windows thread priority only lasts for one session, so if you closed the game in-between it might not have the right priority set.
There could also be other limiting factors that cause it to have to wait for other stuff, but I don't know what those would be.
 
Top