Linux Windowed Mode Issues

jakeh

New Member
#1
Greetings,

I've been having some issues with trying to play the game on the Steam version using Fedora 29. I have set my 1080p display as my primary, but the game always appears on the 1920x1200p display. I have set this option both in MATE's 'Control Center' and NVidia's 'X Server Settings' application. In game, there's no option to choose a display, but most games are able to be set to windowed mode, dragged to the correct display, then set back to full screen. In this case, the application sometimes hides in the taskbar, and not even selecting 'keep this window on top' works. Other times, I see the blue field that is normally behind the options menu, but nothing else is visible.

In either case, it locks up my desktop environment. I then have to force close the application by switching to tty2 and use the kill command. This issue seems to persist after restarting the application, and appears to be tied to switching to windowed mode. I am using the NVidia proprietary driver. Please let me know if I should provide more information.

OS: Fedora release 29 (Twenty Nine) x86_64
Kernel: 5.1.15-200.fc29.x86_64
Resolution: 1920x1080, 1920x1200
DE: MATE
CPU: AMD Ryzen 7 1700 (16) @ 3.000GHz
GPU: NVIDIA GeForce GTX 1070
NVIDIA DRIVER VERSION: 430.26
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#2
I've had similar problems ion windows with unity games, sometimes it's fixed by putting it in windowed mode, then dragging it to the correct screen and closing it normally.

For windows there's -adapter, but unity doesn't support that for linux. You could try messing around with some of the command line options listed under "Unity Standalone Player command line arguments" here, in hopes of it working: https://docs.unity3d.com/560/Documentation/Manual/CommandLineArguments.html
 
Top