Linux: black screen and no sound (with a fix)

Discussion in 'Besiege: Bug Reports' started by zakora, May 16, 2018 at 10:09 AM.

  1. zakora

    zakora New Member

    Hi,

    Just bought the game and unfortunately on first try it is impossible to play it on Linux. When launching the game, it gets stuck on a black screen, also no background music is playing.

    Configuration:
    OS: Linux Fedora 28 (X.org, Gnome 3.28)
    CPU: Intel Core i5-6500
    RAM: 8 Go DDR4
    GPU: AMD HD 7970 (AMD Tahiti)

    Things I tried, but failed:
    - creating a Config.txt file in Besiege_data and setting parameters for the resolution.
    - changing the global.prefs file in "~/.config/unity3d" to manually set the resolution.

    Logs:
    I can't get the game in a non-working state, even after deleting game data and reinstalling the game, so I can't provide any logs. I just remember seeing something like "6 screens detected" when launching Besiege on the command line, which is strange since I have only 1 screen.

    Fix that worked (for me at least):
    In steam, right-click the game, then "properties", tab "Betas", select "experimental" in the drop-down list menu, then the game launches successfully. We can now select back "NONE" in the drop-down menu and it stills work.
    A file "Config.xml" has been automatically created in the process.
    Oddly enough, the versions shown in the main Besiege screen are the same if we select "experimental" or "NONE" (v0.66.0-7835).
     

Share This Page