Lag, FPS drops and Stuttering

#1
Ever since the 0.3 update, my game started to lag more and the stuttering/fps drops got worse. I can't even play with my old huge creations anymore that i was able to play before. Even at low speed, it lags so much. The game is starting to get unplayable for me. I'm using GTX 750 (oc) + i7-4790. I don't get lag/fps drops on any of my other games. I only have the problems on Unity games like Yandere Simulator and Besiege.

Here's a gif showing the severe lag on my huge creations: https://gfycat.com/PlayfulSolidAztecant
Here's a gif on stuttering/fps drops: https://gfycat.com/PaltryAggressiveDikkops
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#3
Ever since the 0.3 update, my game started to lag more and the stuttering/fps drops got worse. I can't even play with my old huge creations anymore that i was able to play before. Even at low speed, it lags so much. The game is starting to get unplayable for me. I'm using GTX 750 (oc) + i7-4790. I don't get lag/fps drops on any of my other games. I only have the problems on Unity games like Yandere Simulator and Besiege.

Here's a gif showing the severe lag on my huge creations: https://gfycat.com/PlayfulSolidAztecant
Here's a gif on stuttering/fps drops: https://gfycat.com/PaltryAggressiveDikkops
Have you tried turning off all the graphics stuff?
If it only happens with unity games, you might have to ask them, maybe it has to do with your graphics card?
 
#4
I have problem with freezing. Sometimes (not every time when i playing Besiege, but often) when i start simulation on buildings, which have 200+ blocks, game freezes. Just freezes for few minutes.
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#5
I have problem with freezing. Sometimes (not every time when i playing Besiege, but often) when i start simulation on buildings, which have 200+ blocks, game freezes. Just freezes for few minutes.
Maybe you have too many skins installed?
 
#6
Maybe you have too many skins installed?
I have 12 skin packs installed. Freezes still happen with turned off skins.
P.s. freezes appeared ~2-3 weeks ago, they continued for several days and then disappeared. Yesterday they appeared again.
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#7
I have 12 skin packs installed. Freezes still happen with turned off skins.
P.s. freezes appeared ~2-3 weeks ago, they continued for several days and then disappeared. Yesterday they appeared again.
Did you just turn of skins, or turn off skins and restart? idk if they actually unload the skins when they're turned off or not
 
#8
Did you just turn of skins, or turn off skins and restart? idk if they actually unload the skins when they're turned off or not
You mean restart simulation? if yes, freezes still happen. I deleted some skinpacks and left only three of them, and freezes still stay here
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#10
You mean restart simulation? if yes, freezes still happen. I deleted some skinpacks and left only three of them, and freezes still stay here
No, restart the game
 
Top