Fire, explosions, sky and water textures missing

Discussion in 'Besiege: Bug Reports' started by Paladius, Jun 10, 2017.

  1. Paladius

    Paladius New Member

    For some reason fire, water and explosion visual effects don't appear when i'm using the sandbox or barren expanse. It works just fine in the old sandbox and i've reinstalled the game to try and fix this. Any suggestions?
    This picture shows how the torch doesn't show any fire, but its heating effect is shown
    OS: Windows 7
     

    Attached Files:

    Last edited: Jun 10, 2017
  2. ITR

    ITR l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ Staff Member

    Have you tried upgrading your graphics drivers?
     
  3. Paladius

    Paladius New Member

    I verified file intergrity through steam, it's fixed now. The sky has appeared on the sandbox as well now.
     
  4. ITR

    ITR l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ Staff Member

    Huh, but it didn't work the first time you reinstalled the game?
     
  5. Paladius

    Paladius New Member

    No, I reinstalled it a few days ago. Also all the other missing effects and textures like the tire tracks on the ground and block previews when building have appeared only yesterday. After verifying the integrity of the game files a few times and reinstall the mod loader it seems to have updated the sandbox completely.
     
  6. Paladius

    Paladius New Member

    It might've helped that i got a new monitor as well. The old one i was using before the texture updated was from 2011.
     
  7. Paladius

    Paladius New Member

    After turning the computer on again. I have found that besiege is having the same problem. There is no rain in tolbrynd, no fire, explosions, water or sky in the sandbox. Help?
     
  8. ITR

    ITR l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ Staff Member

    It kinda sounds like you're somehow starting an old version of the game you have stored somewhere else on your computer. Have you tried starting Besiege through your steam-library?
     
  9. Paladius

    Paladius New Member

    Yeah. That has the same results. I backed up the game files onto my disc.
     
  10. ITR

    ITR l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ Staff Member

    Have you tried reinstalling again?
     
  11. Paladius

    Paladius New Member

    I have reinstalled the game twice already.
     
  12. ITR

    ITR l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ Staff Member

    Reinstalling as in Verifying the Integrity through steam? And not replacing any of the files after you do?
     
  13. Paladius

    Paladius New Member

    I have uninstalled the game numerous times, each time verifying the game files' integrity through steam just in case. When I verify the files it says 1 file needs to be replaced or all files are validated.
     
  14. ITR

    ITR l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ Staff Member

    Okay, try this:
    Delete your Output_Log.txt in Steamapps/Besiege/Besiege_Data
    Start the game, load the sandbox
    Quit the game via the X button of the window
    Upload your Output_Log.txt here (the one that got made when you started the game again)
     
  15. Paladius

    Paladius New Member

    Here
     

    Attached Files:

  16. ITR

    ITR l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ Staff Member

    Hmm, so try deleting the whole Besiege_Data folder then verifying the integrity again, and if that doesn't work, try updating your graphics drivers
    If neither works, then I have no idea
     
  17. Paladius

    Paladius New Member

    I just found this. It might be more helpful with finding the problem. It's from one of the days it failed to load stuff.
     

    Attached Files:

  18. Paladius

    Paladius New Member

    SOLUTION: My mods were out of date. After removing and reinstalling them everything is fixed.
     

Share This Page