Bug pieces values too high on Linux

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#2
Can you share the .bsg file of these machines? Does it happen with all machines, or just the ones you create? Try reinstalling besiege
 
#3
It happens with all I've created and also one I have in steam workshop. The same problem happens in Kubuntu 16.04 and already reinstalled twice
 

Attachments

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#4
Oooh, wait, I think I see why, I think your computer uses ',' for decimals, try switching that or making it use '.' for Besiege.
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
#7
How to fix this? how do you change it only for one application?
I wouldn't know, I guess either change the system locale before playing the game and turn it back afterwards or have some script that changes it for you.
Or you could try to see if you can change just the decimal point settings
 
#8
I wouldn't know, I guess either change the system locale before playing the game and turn it back afterwards or have some script that changes it for you.
Or you could try to see if you can change just the decimal point settings
I guessed the same, so not very helpful, a script would be good, but I cant code that well,
could there be a way to just determine witch settings a linux based system is using and convert it in game while loading? that would be good.
 

Von

Administrator
Staff member
#9
I've spoken with one of the developers are he recommends running the game under the command "LANG=en_GB.UTF-8 ./Besiege.x86_64". He can also go to properties -> launch options and put in "LANG=en_GB.UTF-8 %command%"

He believes that should solve the issue for you.
 
#10
I've spoken with one of the developers are he recommends running the game under the command "LANG=en_GB.UTF-8 ./Besiege.x86_64". He can also go to properties -> launch options and put in "LANG=en_GB.UTF-8 %command%"

He believes that should solve the issue for you.
Thanks, it really worked! but would be good to have known that earlier though. :)
 
#11
Hi, I had the same problem and using (properties -> launch options and put in "LANG=en_GB.UTF-8 %command%") worked, thanks.
I'm using Linux Mint 18.2, with locale as pt_BR.UTF-8. It would be nice to fix that to avoid the need of using this workaround.
 
#12
Hello,
just want to state that I have the same issue. (Debian testing, german locale). Workaround seem to work fine at first glance, but if you don't already know this issue from other games (in my case kerbal) it is hard to realize what goes on. I was pretty sure what the issue is when I saw the rotation speed from the loaded craft (see screenshot).
 

Attachments

Sanpyr

Active Member
#13
Hello,
just want to state that I have the same issue. (Debian testing, german locale). Workaround seem to work fine at first glance, but if you don't already know this issue from other games (in my case kerbal) it is hard to realize what goes on. I was pretty sure what the issue is when I saw the rotation speed from the loaded craft (see screenshot).
are you using mods?
 
Top